PlayStation 5 Update Lets You Know If You’re About to Play the PS4 Version of Game



If you were worried about accidentally playing a last-gen version of a game, a new update to the PlayStation 5 should help with that. A new update to Sony’s console spotted today now warns users when they’re about to play a previous-gen version of a game on the next-gen console.

Spotted by Twitter user @Tidux, a notification pops up on the PS5 when you try to start a PS4 version of a game. This has been a bit of a thorn in some players’ sides, as some reported booting up the PS4 version of a game by accident. This new notification asks you to confirm the game version, and switch to the PS5 version if you’d like.

For games like Call of Duty: Black Ops Cold War, which has a cross-gen bundle where you can get both the PlayStation 4 and PlayStation 5 version of the game, that helps out a fair bit. I’d imagine owners of a brand new PS5 would want to be playing the next-gen version of the game, after all.

The more cross-generational nature of these new consoles has created some gray areas in which versions of a game you might be playing, or whether the console is running the “next-gen” edition. On the Xbox side, Microsoft has already been pushing updates to clarify which games are taking advantage of tools like Auto HDR, and now it seems Sony is following suit.

More clarity is always a good thing, so now I’ll hopefully be a little less paranoid that the Assassin’s Creed: Valhalla executable I’m booting up isn’t the PS5 version. While it’s an understandable issue for early on in the generation, it will be interesting to see how long this particular friction persists, as the gap between the PS4 and PS5 grows.



We will be happy to hear your thoughts

Leave a reply

lkunique
Logo
Enable registration in settings - general
Compare items
  • Total (0)
Compare
0
Shopping cart